更多 选择语言
安全预警 - 涉及浪潮部分产品的Sudo堆缓冲区溢出漏洞安全更新
预警编号:INSPUR-SA-202102-002
初始发布时间:2021-02-09 15:15:41
更新发布时间:2021-02-09 15:15:41
漏洞来源:

sudo官网披露

漏洞影响:

成功利用此漏洞可提权root

漏洞描述:

1月26日,Sudo发布安全通告,修复了安全漏洞CVE-2021-3156。在sudo解析命令行参数时存在基于堆的缓冲区溢出。本地用户无需进行身份验证即可利用此漏洞获得root权限。

CVSS评分:

CVE V3.1 Vector(Base) Base Score V3.1 Vector(Temporal Score) Temporal Score
CVE-2021-3156 AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H 7.8 E:F/RL:O/RC:C 7.2

受影响产品:

产品名称 受影响产品版本 修复补丁包/升级包版本
AS13000 3.7.16.20及之前的版本 sudo-AS13000-cve-2021-3156-update.tar.gz
ICOS 5.8.2之前的版本 icos_update_2021020201
5.8.2 icos_update_2021020202
ICS 5.8.2及之前的版本 升级ICS至5.8.2 后打补丁hotfix001

技术细节:

Sudo在命令参数中转义反斜杠时存在基于堆的缓冲区溢出漏洞。当sudo通过-s或-i命令行选项在shell模式下运行命令时,它将在命令参数中使用反斜杠转义特殊字符。但使用-s或-i标志运行sudoedit时,实际上并未进行转义,从而可能导致缓冲区溢出。

漏洞解决方案:

请用户直接联系客户服务人员,获取补丁以及相关的技术支持。

FAQ:

更新记录:

20210209-V1.0-Initial Release

浪潮安全应急响应对外服务:
浪潮一贯主张尽全力保障产品用户的最终利益,遵循负责任的安全事件披露原则,并通过产品安全问题处理机制处理产品安全问题。
反馈浪潮产品安全问题: https://www.inspur.com/lcjtww/psirt/vulnerability-management/index.html#report_ldbg
订阅浪潮产品安全信息: https://en.inspur.com/en/security_bulletins/vulnerability_subscription/index.html

获取技术支持:https://www.inspur.com/lcjtww/2317452/2317456/2317460/index.html

声明

本文档提供的所有数据和信息仅供参考,且"按原样"提供,不承诺任何明示、默示和法定的担保,包括(但不限于)对适销性、适用性及不侵权的担保。在任何情况下,浪潮或其直接或间接控制的子公司,或其供应商,均不对任何一方因依赖或使用本信息而遭受的任何损失承担责任,包括直接,间接,偶然,必然的商业利润损失或特殊损失。浪潮保留随时更改或更新此文档的权利。


线




×
联系我们
服务器、存储、网络产品购买热线
400-860-6708
ERP、管理软件购买热线
400-018-7700
云服务产品销售热线
400-607-6657